The Server Times Out During the Synchronisation Process
SYMPTOMS
- The server will timeout during the synchronisation process
- Invalid Server Sate reported during synchronisation
- ERROR Invalid server state written to log file
CAUSE
During Synchronisation, WorkgroupShare will query the local Outlook folders before issuing the SELECTFOLDER command. In some very rare cases, where there is a lot of data, it can take a period longer than that of the default timeout for Outlook to respond to this request. If this occurs then the server will terminate the connection. When Outlook does finally respond the connection will be re-established, but the server will not be in the required state; the client will believe that the folder has been selected but the server will be in the pre-authentication state.
RESOLUTION
Increase the server timeout. This may done by creating a value in the registry as follows:
Open RegEdit and navigate to the following key: HKEY_LOCAL_MACHINE\SOFTWARE\Softalk\WorkgroupShare\Advanced
Note: If you do not have an Advanced key, then please create one
Create a serverTimeout DWORD value
Set its data to 1f4 (500 in decimal)
Note: If this value is less than 1000 (decimal) then it will be interpreted as a value in seconds. If the value is 1000 (decimal) or more then it will be interpreted as a value in milliseconds
Please restart the server executable/service for changes to be effected
APPLIES TO
- WorkgroupShare 2.x

